PT-2019-12837

CVE-2019-12516

·

Published

2019-09-10

·

Updated

2019-10-29

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions SlickQuiz plugin versions prior to 1.3.7.2
Description The issue allows SQL Injection by Subscriber users. This can be demonstrated through specific API endpoints such as "/wp-admin/admin.php?page=slickquiz-scores&id=", "/wp-admin/admin.php?page=slickquiz-edit&id=", or "/wp-admin/admin.php?page=slickquiz-preview&id=".
Recommendations For SlickQuiz plugin versions prior to 1.3.7.2, update to version 1.3.7.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the /wp-admin/admin.php endpoint for Subscriber users until a patch is applied. Avoid using the id parameter in the affected API endpoints until the issue is resolved.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾