PT-2019-12967

CVE-2019-12823

·

Published

2019-06-18

·

Updated

2022-05-24

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Craft CMS versions prior to 3.1.31
Description The issue is related to the improper filtering of XML feeds, which allows for cross-site scripting (XSS) attacks. This means that an attacker could potentially inject malicious code into the XML feed, leading to the execution of unauthorized scripts on the user's browser.
Recommendations For versions prior to 3.1.31, update to version 3.1.31 or later to resolve the issue. As a temporary workaround, consider restricting access to XML feeds or implementing additional filtering mechanisms to minimize the risk of XSS attacks.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-W5Q4-Q7WP-QWW6
Found an issue in the description? Have something to add? Feel free to write us 👾