PT-2019-12973
CVE-2019-12831
·
Published
2019-06-15
·
Updated
2019-06-17
Description by
CVSS 3.1
7.2
HighMetricsAV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
MyBB versions prior to 1.8.21
Description
The issue allows an attacker to create a PHP shell in the cache directory of a targeted forum via a crafted XML import. This is achieved by exploiting a default behavior of MySQL on many systems, where strings that are too long for a database column are truncated. For example, a string like
aaaaaaaaaaaaaaaaaaaaaa.php.css can be truncated to aaaaaaaaaaaaaaaaaaaaaa.php due to a 30-character limit, leading to remote code execution.Recommendations
For MyBB versions prior to 1.8.21, update to version 1.8.21 or later to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾