PT-2019-13400
CVE-2019-13536
·
Published
2019-09-11
·
Updated
2021-10-28
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Delta Electronics TPEditor versions 1.94 and prior
Description
The issue is related to multiple heap-based buffer overflow vulnerabilities that can be exploited by processing specially crafted project files. This may allow an attacker to remotely execute arbitrary code.
Recommendations
For Delta Electronics TPEditor versions 1.94 and prior, update to a version later than 1.94 to resolve the issue. As a temporary workaround, consider avoiding the use of specially crafted project files that may trigger the heap-based buffer overflow vulnerabilities. Restrict access to the TPEditor to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾