PT-2019-13407
CVE-2019-13544
·
Published
2019-09-11
·
Updated
2019-10-09
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Delta Electronics TPEditor versions 1.94 and prior
Description
The issue allows remote code execution by exploiting multiple out-of-bounds write vulnerabilities. This can be achieved by processing specially crafted project files.
Recommendations
For versions 1.94 and prior, update to a version later than 1.94 to resolve the issue. As a temporary workaround, consider avoiding the use of specially crafted project files until a patch is available. Restrict access to the TPEditor to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾