PT-2019-13490
CVE-2019-13951
·
Published
2019-07-18
·
Updated
2020-08-24
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
gdnsd versions 3.x before 3.2.1
Description
The issue is related to a stack-based buffer overflow in the set ipv4() function, which can be triggered by a long and malformed IPv4 address in zone data.
Recommendations
For versions prior to 3.2.1, update to version 3.2.1 or later to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾