PT-2019-1404

CVE-2018-16858

·

Published

2018-10-09

·

Updated

2024-06-15

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions LibreOffice versions prior to 6.0.7 LibreOffice versions prior to 6.1.3
Description The issue is caused by a buffer overflow in memory, allowing a remote attacker to execute arbitrary code using a specially crafted document. It was also found that LibreOffice is vulnerable to a directory traversal attack, which could be used to execute arbitrary macros bundled with a document. An attacker could craft a document to execute a Python method from a script in any arbitrary file system location. A directory traversal vulnerability in LibreOffice allows remote attackers to execute code via a specially crafted ODT file.
Recommendations For versions prior to 6.0.7, update to version 6.0.7 or later to resolve the issue. For versions prior to 6.1.3, update to version 6.1.3 or later to resolve the issue. As a temporary workaround, consider disabling the execution of macros from arbitrary file system locations to minimize the risk of exploitation. Avoid opening specially crafted ODT files from untrusted sources until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2018-2447
ALT-PU-2018-2509
CESA-2019_2130
DLA-1669-1
DLA-1947-1
DSA-4381-1
DSA-4501-1
MGASA-2019-0102
OPENSUSE-SU-2019:1929-1
OPENSUSE-SU-2019_1929-1
OPENSUSE-SU-2024:10983-1
RHSA-2019:2130
RHSA-2019_2130
SUSE-SU-2019:1448-1
SUSE-SU-2019:1894-1
SUSE-SU-2019_1894-1
SUSE-SU-2019:2003-1
USN-3883-1
Found an issue in the description? Have something to add? Feel free to write us 👾