PT-2019-14486
CVE-2019-15943
·
Published
2019-09-19
·
Updated
2020-08-24
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Counter-Strike: Global Offensive versions prior to 1.37.1.1
Description
The issue allows remote attackers to achieve code execution or denial of service by creating a gaming server and inviting a victim to this server. This is because a crafted map is mishandled during a memset call.
Recommendations
For versions prior to 1.37.1.1, update to version 1.37.1.1 or later to resolve the issue. As a temporary workaround, consider avoiding joining gaming servers from untrusted sources until the update is applied.
Found an issue in the description? Have something to add? Feel free to write us 👾