PT-2019-15119

CVE-2019-17383

·

Published

2019-10-09

·

Updated

2022-07-19

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions netaddr gem versions prior to 2.0.4 netaddr gem versions prior to 1.5.3
Description The issue is related to misconfigured file permissions in the netaddr gem for Ruby. When a gem is installed, it may result in 0777 permissions in the target filesystem.
Recommendations For versions prior to 1.5.3, update to version 1.5.3 or later. For versions prior to 2.0.4, update to version 2.0.4 or later.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-49PJ-69VF-C689
Found an issue in the description? Have something to add? Feel free to write us 👾