PT-2019-1528

CVE-2019-6227

·

Published

2019-02-11

·

Updated

2020-08-24

Description by

CVSS 2.0
9.3
High
MetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Safari versions prior to 12.0.3 iOS versions prior to 12.1.3 tvOS versions prior to 12.1.2 watchOS versions prior to 5.1.3 iTunes versions prior to 12.9.3 for Windows iCloud for Windows versions prior to 7.10
Description The issue is caused by a buffer overflow in the WebKit display module, allowing a remote attacker to execute arbitrary code using a specially crafted web page. Processing maliciously crafted web content may lead to arbitrary code execution.
Recommendations For Safari versions prior to 12.0.3, update to Safari 12.0.3 or later. For iOS versions prior to 12.1.3, update to iOS 12.1.3 or later. For tvOS versions prior to 12.1.2, update to tvOS 12.1.2 or later. For watchOS versions prior to 5.1.3, update to watchOS 5.1.3 or later. For iTunes versions prior to 12.9.3 for Windows, update to iTunes 12.9.3 for Windows or later. For iCloud for Windows versions prior to 7.10, update to iCloud for Windows 7.10 or later.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
OPENSUSE-SU-2019:0308-1
OPENSUSE-SU-2019_0308-1
OPENSUSE-SU-2019_0309-1
SUSE-SU-2019:0497-1
SUSE-SU-2019:0511-1
Found an issue in the description? Have something to add? Feel free to write us 👾