PT-2019-1568

CVE-2019-1602

·

Published

2019-03-06

·

Updated

2020-10-08

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Cisco NX-OS Software versions prior to 7.0(3)I7(4) Cisco NX-OS Software versions prior to 7.0(3)F3(5)
Description A vulnerability in the filesystem permissions of Cisco NX-OS Software could allow an authenticated, local attacker to access sensitive data that could be used to elevate their privileges to administrator. The vulnerability is due to improper implementation of filesystem permissions. An attacker could exploit this vulnerability by logging in to the CLI of an affected device, accessing a specific file, and leveraging this information to authenticate to the "NX-API server". A successful exploit could allow an attacker to make configuration changes as administrator. Note that "NX-API" is disabled by default.
Recommendations For versions prior to 7.0(3)I7(4), update to version 7.0(3)I7(4) or later. For versions prior to 7.0(3)F3(5), update to version 7.0(3)F3(5) or later. As a temporary workaround, consider restricting access to the affected devices until a patch is available.
Exploitability
Fix
Vendors
Affected products
Weakness enumeration
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾