PT-2019-16673
CVE-2019-3729
·
Published
2019-09-30
·
Updated
2022-04-12
Description by
CVSS 2.0
2.7
LowMetricsAV:A/AC:L/Au:S/C:N/I:N/A:P
Name of the Vulnerable Software and Affected Versions
RSA BSAFE Micro Edition Suite versions prior to 4.4
Description
The issue is related to a Heap-based Buffer Overflow vulnerability when parsing ECDSA signature. A malicious user with adjacent network access could potentially exploit this vulnerability to cause a crash in the library of the affected system.
Recommendations
For RSA BSAFE Micro Edition Suite versions prior to 4.4, update to version 4.4 or later to resolve the issue. As a temporary workaround, consider restricting access to the library to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾