PT-2019-16711

CVE-2019-3781

·

Published

2019-03-07

·

Updated

2020-10-19

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Cloud Foundry CLI versions prior to 6.43.0
Description The issue improperly exposes passwords when verbose, trace, or debugging modes are enabled. A malicious user, either local and unauthenticated or remote and authenticated, with access to logs may be able to obtain part or all of a user's password.
Recommendations For versions prior to 6.43.0, update to version 6.43.0 or later to resolve the issue. As a temporary workaround, consider disabling verbose, trace, and debugging modes to minimize the risk of password exposure. Restrict access to logs to prevent unauthorized users from gaining access to sensitive information.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
SUSE-SU-2019:1220-1
SUSE-SU-2019_1220-1
SUSE-SU-2019:1220-2
SUSE-SU-2019_1220-2
Found an issue in the description? Have something to add? Feel free to write us 👾