PT-2019-16716

CVE-2019-3786

·

Published

2019-04-24

·

Updated

2020-10-16

Description by

CVSS 3.1
7.7
High
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions Cloud Foundry BOSH Backup and Restore CLI versions prior to 1.5.0
Description The issue allows a remote authenticated malicious user to modify the metadata file of a BOSH Backup and Restore job, enabling them to request extra backup files from different jobs upon restore. This is possible because the authenticity of backup scripts in BOSH is not checked. The vulnerability specifically affects clusters deployed with the BBR job for etcd in the cfcr-etcd-release.
Recommendations For Cloud Foundry BOSH Backup and Restore CLI versions prior to 1.5.0, update to version 1.5.0 or later to resolve the issue.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾