PT-2019-18396

CVE-2019-6982

·

Published

2019-01-28

·

Updated

2019-01-28

Description by

CVSS 3.1
5.5
Medium
MetricsAV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions Foxit 3D Plugin Beta versions prior to 9.4.0.16807 for Foxit Reader and PhantomPDF
Description The issue arises from the improper handling of a logic exception in the IFXASSERT function, leading to an Out-of-Bounds Write when the application handles certain PDF files with specifically crafted 3D content. This can cause the application to crash.
Recommendations For Foxit 3D Plugin Beta versions prior to 9.4.0.16807, update to version 9.4.0.16807 or later to resolve the issue. As a temporary workaround, consider avoiding the handling of PDF files with crafted 3D content until the update is applied.
Exploitability
Fix
Impacts
Vendors
Affected products
Weakness enumeration
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾