PT-2019-18813
CVE-2019-7896
·
Published
2019-08-02
·
Updated
2022-05-24
Description by
CVSS 3.1
7.2
HighMetricsAV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Magento 2.1 versions prior to 2.1.18
Magento 2.2 versions prior to 2.2.9
Magento 2.3 versions prior to 2.3.2
Description
A remote code execution issue exists, allowing an authenticated user with administrator privileges to layouts to execute arbitrary code. This can be achieved through a combination of product import, a crafted csv file, and XML layout update.
Recommendations
For Magento 2.1 versions prior to 2.1.18, update to version 2.1.18 or later.
For Magento 2.2 versions prior to 2.2.9, update to version 2.2.9 or later.
For Magento 2.3 versions prior to 2.3.2, update to version 2.3.2 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾