PT-2019-18914
CVE-2019-8138
·
Published
2019-11-05
·
Updated
2022-05-24
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Magento 2.2 versions prior to 2.2.10
Magento 2.3 versions prior to 2.3.3 or 2.3.2-p1
Description
A stored cross-site scripting (XSS) issue exists, allowing an authenticated user to execute arbitrary JavaScript code. This can be achieved by providing an arbitrary API endpoint that will not be checked by the sale pickup event.
Recommendations
For Magento 2.2 versions prior to 2.2.10, update to version 2.2.10 or later.
For Magento 2.3 versions prior to 2.3.3, update to version 2.3.3 or later.
For Magento 2.3 versions prior to 2.3.2-p1, update to version 2.3.2-p1 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾