PT-2019-19142
CVE-2019-8662
·
Published
2019-12-18
·
Updated
2020-08-24
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
iOS versions prior to 12.4
macOS Mojave versions prior to 10.14.6
tvOS versions prior to 12.4
watchOS versions prior to 5.3
Description
The issue allows an attacker to trigger a use-after-free in an application deserializing an untrusted NSDictionary. This can be exploited by an attacker.
Recommendations
For iOS versions prior to 12.4, update to iOS 12.4 or later.
For macOS Mojave versions prior to 10.14.6, update to macOS Mojave 10.14.6 or later.
For tvOS versions prior to 12.4, update to tvOS 12.4 or later.
For watchOS versions prior to 5.3, update to watchOS 5.3 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾