PT-2019-19782
CVE-2019-9658
·
Published
2019-03-11
·
Updated
2020-10-01
Description by
CVSS 3.1
5.3
MediumMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Checkstyle versions prior to 8.18
Description
The issue allows Checkstyle to load external DTDs by default, which can potentially lead to denial of service attacks or the leaking of confidential information.
Recommendations
For versions prior to 8.18, update to version 8.18 or later to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾