PT-2019-2300

CVE-2019-1003030

·

Published

2019-03-08

·

Updated

2025-10-24

Description by

CVSS 3.1
9.9
Critical
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Jenkins Pipeline: Groovy Plugin versions 2.63 and earlier
Description A sandbox bypass issue exists that allows attackers who can control pipeline scripts to execute arbitrary code on the Jenkins master JVM. The vulnerability is related to errors in handling input data during code syntax analysis in components such as pom.xml and CpsGroovyShell.java. This could enable a remote attacker to bypass sandbox restrictions and execute arbitrary code.
Recommendations For Jenkins Pipeline: Groovy Plugin versions 2.63 and earlier, update to a version later than 2.63 to resolve the issue. As a temporary workaround, consider restricting access to the Jenkins master JVM to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-R6MC-MRVR-23CR
RHSA-2019:0739
Found an issue in the description? Have something to add? Feel free to write us 👾