PT-2019-2588
CVE-2019-3839
·
Published
2019-02-07
·
Updated
2022-05-02
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Ghostscript versions prior to 9.27
Description
The issue is related to the incorrect usage of privileged APIs in the Ghostscript PostScript file conversion program. Exploitation of this issue may allow a remote attacker to access the file system, bypassing the restrictions imposed by -dSAFER, using a specially crafted PostScript file.
Recommendations
For Ghostscript versions prior to 9.27, update to version 9.27 or later to resolve the issue. As a temporary workaround, consider restricting access to privileged operators to minimize the risk of exploitation. Avoid using specially crafted PostScript files that could exploit this flaw until the issue is resolved.
Found an issue in the description? Have something to add? Feel free to write us 👾