PT-2019-2934

CVE-2019-9917

·

Published

2019-03-27

·

Updated

2024-06-15

Description by

CVSS 3.1
6.5
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions ZNC versions prior to 1.7.3-rc1
Description The issue allows an existing remote user to cause a Denial of Service (crash) via invalid encoding. It is due to insufficient input validation in the mechanism for disconnecting clients from the IRC server or a selected channel. This can be exploited by a remote attacker to cause a denial of service.
Recommendations For versions prior to 1.7.3-rc1, update to version 1.7.3-rc1 or later to resolve the issue. As a temporary workaround, consider restricting access to the ZNC service to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
DSA-4463-1
MGASA-2019-0262
OPENSUSE-SU-2019:1166-1
OPENSUSE-SU-2019_1166-1
OPENSUSE-SU-2019:1775-1
OPENSUSE-SU-2019_1775-1
OPENSUSE-SU-2019:1859-1
OPENSUSE-SU-2024:11542-1
USN-3950-1
Found an issue in the description? Have something to add? Feel free to write us 👾