PT-2019-3102

CVE-2019-1582

·

Published

2019-08-21

·

Updated

2020-08-24

Description by

CVSS 2.0
9.0
High
MetricsAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions PAN-OS versions 8.1.9 and earlier PAN-OS versions 9.0.3 and earlier
Description The issue is related to memory corruption in the PAN-OS system, which can be caused by an administrative user rekeying the current client interactive session. This can lead to arbitrary memory corruption. The vulnerability is associated with a buffer overflow in memory, which can be exploited by a remote attacker to cause memory corruption or a denial of service.
Recommendations For PAN-OS versions 8.1.9 and earlier, update to a version later than 8.1.9 to resolve the issue. For PAN-OS versions 9.0.3 and earlier, update to a version later than 9.0.3 to resolve the issue. As a temporary workaround, consider restricting the ability of administrative users to rekey the current client interactive session until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾