PT-2019-3242

CVE-2019-13638

·

Published

2019-07-22

·

Updated

2026-09-18

Description by

CVSS 2.0
9.3
High
MetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions GNU patch versions prior to 2.7.7
Description The issue is related to the do ed script function in the GNU Patch utility, which fails to neutralize special elements used in operating system commands. This can be exploited by opening a crafted patch file containing an ed style diff payload with shell metacharacters, potentially allowing an attacker to access confidential information and execute arbitrary commands.
Recommendations For GNU patch versions prior to 2.7.7, update to version 2.7.7 or later to resolve the issue. As a temporary workaround, consider avoiding the use of crafted patch files that contain ed style diff payloads with shell metacharacters until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
AZL-35106
AZL-6790
CESA-2019_2798
CESA-2019_2964
CLEANSTART-2026-LC02147
CLEANSTART-2026-NA21773
CLEANSTART-2026-PM79547
DLA-1864-1
DSA-4489-1
JLSEC-2026-17
MGASA-2020-0093
RHSA-2019:2798
RHSA-2019_2798
RHSA-2019:2964
RHSA-2019_2964
RHSA-2019:3757
RHSA-2019:3758
RHSA-2019:4061
USN-4071-1
USN-4071-2
Found an issue in the description? Have something to add? Feel free to write us 👾