PT-2019-4130

CVE-2019-3465

·

Published

2019-11-05

·

Updated

2026-09-15

Description by

CVSS 2.0
9.0
High
MetricsAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Rob Richards XmlSecLibs versions prior to 3.0.3 SimpleSAMLphp (affected versions not specified)
Description The issue is related to incorrect validation of cryptographic signatures in XML messages. This allows an authenticated attacker to impersonate others or elevate privileges by creating a crafted XML message. Exploitation of the vulnerability may also enable a remote attacker to access confidential data, compromise its integrity, and cause a denial of service.
Recommendations For Rob Richards XmlSecLibs versions prior to 3.0.3, update to version 3.0.3 or later to resolve the issue. For SimpleSAMLphp, at the moment, there is no information about a newer version that contains a fix for this vulnerability.
Exploitability
Exploit
Impacts
Vendors
Affected products
Related identifiers
GHSA-PQM6-CGWR-X6PF
DLA-1983-1
DSA-4560-1
USN-8770-1
Found an issue in the description? Have something to add? Feel free to write us 👾