PT-2019-4207

CVE-2019-19070

·

Published

2019-10-01

·

Updated

2026-10-18

Description by

CVSS 2.0
7.8
High
MetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions Linux kernel versions through 5.3.11
Description A memory leak in the spi gpio probe() function in drivers/spi/spi-gpio.c allows attackers to cause a denial of service by triggering devm add action or reset() failures. This issue is disputed by third parties because the system must have already been out of memory before the probe began.
Recommendations For Linux kernel versions through 5.3.11, update to a version later than 5.3.11 to resolve the issue. As a temporary workaround, consider restricting system resources to prevent memory exhaustion.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2020-1003
ALT-PU-2020-1010
ALT-PU-2020-1043
ALT-PU-2020-1198
ALT-PU-2020-1421
ALT-PU-2020-1450
ALT-PU-2020-1501
ALT-PU-2020-1714
ALT-PU-2020-2410
ALT-PU-2020-2433
ALT-PU-2021-1870
ECHO-E5D0-971C-CE39
Found an issue in the description? Have something to add? Feel free to write us 👾