PT-2019-4247

CVE-2019-3650

·

Published

2019-11-12

·

Updated

2021-07-21

Description by

CVSS 3.1
6.5
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions McAfee Advanced Threat Defense versions prior to 4.8
Description The issue allows remote authenticated attackers to gain access to the atduser credentials via carefully constructed GET requests, extracting insecurely stored information from the database. This is due to insufficient input validation, which can be exploited by a remote attacker to obtain unauthorized access to the atduser credentials using specially formed GET requests.
Recommendations For versions prior to 4.8, update to version 4.8 or later to resolve the issue. As a temporary workaround, consider restricting access to the database and limiting the use of GET requests to minimize the risk of exploitation. Avoid using insecurely stored information in the database until the issue is resolved.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾