PT-2019-4604

CVE-2019-10912

·

Published

2019-04-17

·

Updated

2020-02-12

Description by

CVSS 2.0
7.5
High
MetricsAV:N/AC:L/Au:S/C:P/I:C/A:N
Name of the Vulnerable Software and Affected Versions Symfony versions prior to 2.8.50 Symfony versions 3.x prior to 3.4.26 Symfony versions 4.x prior to 4.1.12 Symfony versions 4.2.x prior to 4.2.7
Description The issue is related to the symfony/cache and symfony/phpunit-bridge components, where objects containing bad user input can be cached. Upon serialization or unserialization, this could lead to the deletion of files accessible by the current user. The vulnerability is also related to the exploitation of the sleep and wakeup functions, allowing an attacker to restore invalid data in memory, potentially compromising data integrity.
Recommendations For Symfony versions prior to 2.8.50, update to version 2.8.50 or later. For Symfony versions 3.x prior to 3.4.26, update to version 3.4.26 or later. For Symfony versions 4.x prior to 4.1.12, update to version 4.1.12 or later. For Symfony versions 4.2.x prior to 4.2.7, update to version 4.2.7 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-W2FR-65VP-MXW3
DSA-4441-1
Found an issue in the description? Have something to add? Feel free to write us 👾