PT-2019-4695
CVE-2019-19602
·
Published
2019-11-28
·
Updated
2021-05-28
Description by
CVSS 2.0
6.8
MediumMetricsAV:L/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 5.4.2
Description
The issue is related to the
fpregs state valid function in the Linux kernel, which can be exploited by context-dependent attackers to cause a denial of service or possibly have other unspecified impacts due to incorrect caching. This is demonstrated by the mishandling of signal-based non-cooperative preemption in certain environments. The vulnerability may also allow an attacker to disclose protected information or cause a denial of service, as it is caused by a "race condition" situation.Recommendations
For Linux kernel versions prior to 5.4.2, update to version 5.4.2 or later to resolve the issue.
At the moment, there is no information about additional mitigation measures for this vulnerability.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾