PT-2019-4782

CVE-2018-16228

·

Published

2019-09-30

·

Updated

2024-06-15

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions tcpdump versions prior to 4.9.3
Description The issue is related to a buffer over-read in the HNCP parser of the tcpdump utility, specifically in the print-hncp.c:print prefix() function. This can be exploited by a remote attacker to cause a denial of service. The vulnerability is also related to a heap-based buffer over-read in the aoe print function in print-aoe.c and the lookup emem function in addrtoname.c.
Recommendations For versions prior to 4.9.3, update to version 4.9.3 or later to resolve the issue. As a temporary workaround, consider restricting the use of the HNCP parser and the affected functions until a patch is available. Avoid using the print-hncp.c:print prefix() function and the aoe print function in print-aoe.c until the issue is resolved. Restrict access to the lookup emem function in addrtoname.c to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
ALT-PU-2019-3120
ALT-PU-2020-3563
ALT-PU-2021-1433
CESA-2020_4760
DLA-1955-1
DSA-4547-1
MGASA-2019-0297
OPENSUSE-SU-2019:2344-1
OPENSUSE-SU-2019_2344-1
OPENSUSE-SU-2019:2348-1
OPENSUSE-SU-2019_2348-1
OPENSUSE-SU-2024:11425-1
RHSA-2020:4760
RHSA-2020_4760
RLSA-2020:4760
SUSE-SU-2019:2674-1
SUSE-SU-2020:3360-1
USN-4252-1
USN-4252-2
Found an issue in the description? Have something to add? Feel free to write us 👾