PT-2019-4888

CVE-2019-12523

·

Published

2019-11-14

·

Updated

2026-10-21

Description by

CVSS 3.1
8.5
High
MetricsAV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Squid versions prior to 4.9
Description The issue exists due to insufficient input validation in the Squid proxy server, allowing a remote attacker to access restricted HTTP servers using a specially crafted HTTP request. When handling a URN request, a corresponding HTTP request is made without going through the access checks that incoming HTTP requests go through, causing all access checks to be bypassed. This allows access to restricted HTTP servers, such as those that only listen on localhost.
Recommendations For Squid versions prior to 4.9, update to version 4.9 or later to resolve the issue. As a temporary workaround, consider restricting access to the URN request handling functionality until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALSA-2020:4743
ALT-PU-2020-1479
ALT-PU-2020-1494
CESA-2020_4743
CLSA-2026-1776878817
DLA-2278-1
DLA-2278-2
DSA-4682-1
MGASA-2019-0382
OPENSUSE-SU-2019:2540-1
OPENSUSE-SU-2019_2540-1
OPENSUSE-SU-2019:2541-1
OPENSUSE-SU-2019_2541-1
OPENSUSE-SU-2024:11403-1
RHSA-2020:4743
RHSA-2020_4743
RLSA-2020:4743
SUSE-SU-2019:2975-1
SUSE-SU-2019_2975-1
SUSE-SU-2019:3067-1
SUSE-SU-2019_3067-1
SUSE-SU-2020:0661-1
SUSE-SU-2020_0661-1
SUSE-SU-2020:14460-1
SUSE-SU-2022:14908-1
SUSE-SU-2022_14908-1
USN-4213-1
USN-4446-1
USN-4446-2
Found an issue in the description? Have something to add? Feel free to write us 👾