PT-2019-5009
CVE-2019-11036
·
Published
2019-04-29
·
Updated
2024-06-15
Description by
CVSS 2.0
10
HighMetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
PHP EXIF extension versions 7.1.x through 7.1.28
PHP EXIF extension versions 7.2.x through 7.2.17
PHP EXIF extension versions 7.3.x through 7.3.4
Description
The issue is related to the PHP EXIF extension, where processing certain files can cause it to read past the allocated buffer in the
exif process IFD TAG function. This may lead to information disclosure or a crash, potentially allowing a remote attacker to gain unauthorized access to information or cause a denial of service.Recommendations
For PHP EXIF extension versions 7.1.x through 7.1.28, update to version 7.1.29 or later.
For PHP EXIF extension versions 7.2.x through 7.2.17, update to version 7.2.18 or later.
For PHP EXIF extension versions 7.3.x through 7.3.4, update to version 7.3.5 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾