PT-2019-5047
CVE-2019-11046
·
Published
2019-12-21
·
Updated
2024-06-15
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:C/I:N/A:N
Name of the Vulnerable Software and Affected Versions
PHP versions 7.2.x below 7.2.26
PHP versions 7.3.x below 7.3.13
PHP version 7.4.0
Description
The issue is related to a buffer overflow vulnerability in the PHP bcmath extension functions. On some systems, including Windows, these functions can be tricked into reading beyond the allocated space by supplying a string containing characters that are identified as numeric by the OS but aren't ASCII numbers. This can lead to the disclosure of the content of some memory locations. The vulnerability may allow a remote attacker to gain unauthorized access to information.
Recommendations
For PHP version 7.2.x below 7.2.26, update to version 7.2.26 or later.
For PHP version 7.3.x below 7.3.13, update to version 7.3.13 or later.
For PHP version 7.4.0, update to a later version.
As a temporary workaround, consider disabling the bcmath extension functions until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾