PT-2019-5137

CVE-2019-14806

·

Published

2019-05-14

·

Updated

2026-10-01

Description by

CVSS 4.0
8.7
High
MetricsAV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions Pallets Werkzeug versions prior to 0.15.3
Description The issue is related to insufficient entropy in the PIN selection of the generate function in the Werkzeug web application library. This can allow a remote attacker to gain unauthorized access to confidential data. The problem is particularly pronounced when Werkzeug is used with Docker, as Docker containers share the same machine ID, leading to insufficient debugger PIN randomness.
Recommendations For versions prior to 0.15.3, update to version 0.15.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the generate function in the src/werkzeug/debug/ init .py file until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
GHSA-GQ9M-QVPX-68HC
ALT-PU-2019-2595
MGASA-2020-0004
OPENSUSE-SU-2019:2118-1
OPENSUSE-SU-2019_2118-1
OPENSUSE-SU-2019:2145-1
OPENSUSE-SU-2019_2145-1
OPENSUSE-SU-2024:11213-1
OPENSUSE-SU-2024:14042-1
OPENSUSE-SU-2026:11943-1
PYSEC-2019-140
SUSE-SU-2019:2308-1
SUSE-SU-2019_2308-1
SUSE-SU-2019:2358-1
SUSE-SU-2019:2365-1
SUSE-SU-2019_2365-1
SUSE-SU-2019:2365-2
SUSE-SU-2019_2365-2
SUSE-SU-2019:2400-1
SUSE-SU-2022:3977-1
SUSE-SU-2022_3977-1
USN-4655-1
Found an issue in the description? Have something to add? Feel free to write us 👾