PT-2019-5357
CVE-2019-12474
·
Published
2017-08-22
·
Updated
2025-09-29
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:C/I:N/A:N
Name of the Vulnerable Software and Affected Versions
MediaWiki versions 1.23.0 through 1.32.1
Description
The issue is related to an information leak in MediaWiki, where privileged API responses may be cached publicly, potentially revealing whether a recent change has been patrolled. This could allow a remote attacker to gain unauthorized access to protected information.
Recommendations
For MediaWiki versions 1.23.0 through 1.32.1, update to version 1.32.2, 1.31.2, 1.30.2, or 1.27.6 to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾