PT-2019-5755
CVE-2019-15694
·
Published
2019-12-20
·
Updated
2024-06-15
Description by
CVSS 3.1
7.2
HighMetricsAV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
TigerVNC versions prior to 1.10.1
Description
The issue is related to a buffer data boundary overflow in the DecodeManager::decodeRect function of the VNC TigerVNC software. This could allow a remote attacker to access confidential data, compromise its integrity, and cause a denial of service. The vulnerability occurs due to a sign error in processing MemOutStream and could potentially result in remote code execution via network connectivity.
Recommendations
For TigerVNC versions prior to 1.10.1, update to version 1.10.1 or later to resolve the issue. As a temporary workaround, consider restricting network connectivity to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾