PT-2019-5765
CVE-2019-20044
·
Published
2019-12-27
·
Updated
2024-06-15
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Zsh versions prior to 5.8
Description
The issue is related to the incorrect overwriting of the saved uid in the Zsh command-line shell, allowing attackers who can execute commands to regain dropped privileges. This can be achieved by executing
MODULE PATH=/dir/with/module zmodload with a module that calls setuid(), thus restoring the original privileges. The exploitation of this issue may allow an attacker to access confidential data, compromise its integrity, and cause a denial of service.Recommendations
For versions prior to 5.8, update to version 5.8 or later to resolve the issue.
As a temporary workaround, consider restricting the use of the
zmodload command with modules that call setuid() to minimize the risk of exploitation. Found an issue in the description? Have something to add? Feel free to write us 👾