PT-2019-6792
CVE-2012-5577
·
Published
2019-10-28
·
Updated
2020-03-11
Description by
CVSS 4.0
8.7
HighMetricsAV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions
Python keyring lib versions prior to 0.10
Description
The issue concerns the Python keyring library, where versions before 0.10 created keyring files with world-readable permissions. This could potentially expose sensitive information.
Recommendations
For versions prior to 0.10, update to version 0.10 or later to ensure keyring files are created with appropriate permissions, restricting access to sensitive information.
Found an issue in the description? Have something to add? Feel free to write us 👾