PT-2019-7116

CVE-2014-4550

·

Published

2019-12-27

·

Updated

2019-12-30

Description by

CVSS 2.0
4.3
Medium
MetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions Shortcode Ninja plugin versions 1.4 and earlier
Description A cross-site scripting (XSS) issue allows remote attackers to inject arbitrary web script or HTML via the shortcode parameter. This can be exploited by injecting malicious code into the shortcode parameter, potentially leading to unauthorized actions on the affected website.
Recommendations For Shortcode Ninja plugin versions 1.4 and earlier, update to a version later than 1.4 to resolve the issue. As a temporary workaround, consider restricting access to the preview-shortcode-external.php file to minimize the risk of exploitation. Avoid using the shortcode parameter in the affected plugin until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾