PT-2019-7162

CVE-2015-1006

·

Published

2019-05-10

·

Updated

2019-10-09

Description by

CVSS 2.0
10
High
MetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Opto 22 PAC Project Professional versions prior to R9.4006 Opto 22 PAC Project Basic versions prior to R9.4006 Opto 22 PAC Display Basic versions prior to R9.4f Opto 22 PAC Display Professional versions prior to R9.4f Opto 22 OptoOPCServer versions prior to R9.4c Opto 22 OptoDataLink versions prior to R9.4d and versions installed by PAC Project installer prior to R9.4006
Description A vulnerable file is susceptible to a heap-based buffer overflow condition that may allow remote code execution on the target system.
Recommendations For Opto 22 PAC Project Professional versions prior to R9.4006, upgrade to version R9.4006 or later. For Opto 22 PAC Project Basic versions prior to R9.4006, upgrade to version R9.4006 or later. For Opto 22 PAC Display Basic versions prior to R9.4f, upgrade to version R9.4f or later. For Opto 22 PAC Display Professional versions prior to R9.4f, upgrade to version R9.4f or later. For Opto 22 OptoOPCServer versions prior to R9.4c, upgrade to version R9.4c or later. For Opto 22 OptoDataLink versions prior to R9.4d and versions installed by PAC Project installer prior to R9.4006, upgrade to version R9.4d or later and ensure the PAC Project installer is version R9.4006 or later.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾