PT-2019-9987
CVE-2018-20106
·
Published
2019-03-15
·
Updated
2019-10-09
Description by
CVSS 2.0
9.3
HighMetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
yast2-printer versions prior to 4.0.3
Description
The issue is related to the SMB printer settings in yast2-printer, where passwords are not properly escaped, allowing for code execution as root if a password with special characters, such as backticks, is supplied. This requires tricking the root user into entering such a password in yast.
Recommendations
For versions prior to 4.0.3, update to version 4.0.3 or later to resolve the issue. As a temporary workaround, consider avoiding the use of passwords with special characters, such as backticks, in the SMB printer settings until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾