PT-2020-10485
CVE-2019-20509
·
Published
2020-03-10
·
Updated
2020-06-10
Description by
CVSS 3.1
6.5
MediumMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
libarchive versions prior to 3.4.1
Description
The issue allows remote attackers to cause a denial of service, resulting in a heap-based buffer over-read and application crash, via a crafted LHA archive. This is due to the failure to ensure valid sizes for UTF-16 input in the archive read support format lha.c file.
Recommendations
For versions prior to 3.4.1, update to version 3.4.1 or later to resolve the issue. As a temporary workaround, consider restricting the handling of LHA archives to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾