PT-2020-10851
CVE-2019-20887
·
Published
2020-06-19
·
Updated
2021-07-21
Description by
CVSS 3.1
4.3
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Mattermost Server versions prior to 5.7.1
Mattermost Server versions prior to 5.6.4
Mattermost Server versions prior to 5.5.3
Mattermost Server versions prior to 4.10.6
Description
The issue concerns the Mattermost Server not honoring flags API permissions, which affects the decision on whether a user can receive intra-team posts.
Recommendations
For versions prior to 5.7.1, update to version 5.7.1 or later.
For versions prior to 5.6.4, update to version 5.6.4 or later.
For versions prior to 5.5.3, update to version 5.5.3 or later.
For versions prior to 4.10.6, update to version 4.10.6 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾