PT-2020-12209
CVE-2020-10568
·
Published
2020-03-14
·
Updated
2020-03-19
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
sitepress-multilingual-cms (WPML) plugin versions prior to 4.3.7-b.2
Description
The issue is due to a loose comparison, leading to CSRF, which can result in remote code execution in includes/class-wp-installer.php via a series of requests that leverage unintended comparisons of integers to strings.
Recommendations
For versions prior to 4.3.7-b.2, update to version 4.3.7-b.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the includes/class-wp-installer.php file to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾