PT-2020-12334
CVE-2020-10803
·
Published
2020-03-22
·
Updated
2024-06-15
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
phpMyAdmin versions 4.x through 4.9.4
phpMyAdmin versions 5.x through 5.0.1
Description
A SQL injection issue was found where malicious code could be used to trigger an XSS attack through retrieving and displaying results. This occurs in files such as tbl get field.php and libraries/classes/Display/Results.php. The attacker must be able to insert crafted data into certain database tables, which when retrieved, for instance, through the Browse tab, can trigger the XSS attack.
Recommendations
For phpMyAdmin versions 4.x through 4.9.4, update to version 4.9.5 or later.
For phpMyAdmin versions 5.x through 5.0.1, update to version 5.0.2 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾