PT-2020-12335
CVE-2020-10804
·
Published
2020-03-22
·
Updated
2024-06-15
Description by
CVSS 3.1
8.0
HighMetricsAV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
phpMyAdmin versions 4.x through 4.9.4
phpMyAdmin versions 5.x through 5.0.1
Description
A SQL injection issue was found in the retrieval of the current username, specifically in libraries/classes/Server/Privileges.php and libraries/classes/UserPassword.php. This could allow a malicious user with server access to create a crafted username and trick a victim into performing specific actions with that user account, such as editing its privileges.
Recommendations
For phpMyAdmin versions 4.x through 4.9.4, update to version 4.9.5 or later.
For phpMyAdmin versions 5.x through 5.0.1, update to version 5.0.2 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾