PT-2020-12513
CVE-2020-11052
·
Published
2020-05-07
·
Updated
2020-05-13
Description by
CVSS 3.1
8.3
HighMetricsAV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions
Sorcery versions prior to 0.15.0
Description
The issue is related to a brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule prevents a brute force attack for the defined lockout period, but once expired, protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout.
Recommendations
For Sorcery versions prior to 0.15.0, upgrade to version 0.15.0 to resolve the issue. As a temporary workaround, consider monkey patching the
authenticate method provided by Sorcery until a patch is available.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾