PT-2020-12628

CVE-2020-11465

·

Published

2020-04-01

·

Updated

2021-07-21

Description by

CVSS 3.1
8.8
High
MetricsAC:L/AV:N/A:H/C:H/I:H/PR:L/S:U/UI:N
Name of the Vulnerable Software and Affected Versions Deskpro versions prior to 2019.8.0
Description An issue was discovered where the "/api/apps/*" endpoints failed to properly validate a user's privilege. This allows an attacker to control or install helpdesk applications and leak current applications' configurations, including those used as user sources for authentication. As a result, an attacker can forge valid authentication models that resemble any user on the system.
Recommendations For versions prior to 2019.8.0, update to version 2019.8.0 or later to resolve the issue. As a temporary workaround, consider restricting access to the "/api/apps/*" endpoints to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Weakness enumeration
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾