PT-2020-13811

CVE-2020-13973

·

Published

2020-06-09

·

Updated

2022-02-10

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions OWASP json-sanitizer versions prior to 1.2.1
Description The issue allows an attacker who controls a substring of the input JSON, and controls another substring adjacent to a SCRIPT element in which the output is embedded as JavaScript, to potentially confuse the HTML parser as to where the SCRIPT element ends. This could cause non-script content to be interpreted as JavaScript, leading to a cross-site scripting (XSS) attack.
Recommendations For OWASP json-sanitizer versions prior to 1.2.1, update to version 1.2.1 or later to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-G8JJ-899Q-8X3J
Found an issue in the description? Have something to add? Feel free to write us 👾