PT-2020-14327

CVE-2020-15269

·

Published

2020-10-20

·

Updated

2021-11-18

Description by

CVSS 3.1
9.1
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Name of the Vulnerable Software and Affected Versions Spree versions prior to 3.7.11 Spree versions prior to 4.0.4 Spree versions prior to 4.1.11
Description The issue allows expired user tokens to be used for accessing Storefront API v2 endpoints. This could be exploited by a perpetrator who previously obtained an old expired user token.
Recommendations For versions prior to 3.7.11, upgrade to version 3.7.11. For versions prior to 4.0.4, upgrade to version 4.0.4. For versions prior to 4.1.11, upgrade to version 4.1.11. As a temporary workaround without upgrading, create a decorator file app/controllers/spree/api/v2/base controller decorator.rb with the specified contents to override the spree current user method in Spree::Api::V2::BaseController.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-F8CM-364F-Q9QH
Found an issue in the description? Have something to add? Feel free to write us 👾